Несколько слов о программе SatIR

Справочное руководство по работе с программой SatIR v. 1.7

Несколько слов о программе SatIR

Для чего и для кого эта программа? Чтобы ответить на эти вопросы кратко, много слов не нужно:

● SatIR может быть полезна для любителей астрономии, которые фотографируют метеоры или искуственные спутники Земли (ИСЗ).

● SatIR позволяет идентифицировать кадр со звёздами, т.е. привязать его к звёздному каталогу.

● SatIR позволяет измерить координаты концов трека ИСЗ или метеора.

● SatIR позволяет идентифицировать ИСЗ, трек которого изображён на загруженной фотографии.

Может возникнуть вопрос - зачем для такой, казалось бы, узкой задачи, понадобилось создавать отдельную программу? Необходимость такой программы диктуется теми проблемами, с которыми сталкиваются любители астрономии (ЛА) при съёмке метеоров ("метеорщики") и ИСЗ ("сателлитчики" - от англ. "satellite", спутник).

Рассмотрим задачи "метеорщика"-фотографа:

1. На фотографии, помимо следов от метеоров, могут быть и треки ИСЗ -- такие события нужно отсеять, т.к. статистика по фотографическим метеорам из-за их тусклости, не позволяет пренебрегать даже единичными ложными треками. SatIR позволяет проверить, принадлежит ли трек на снимке какому-либо ИСЗ, или же это метеор. При этом, конечно, доступна информация не о всех ИСЗ, но на широких полях зрения (20о-60о) заметный трек могут оставить только довольно яркие ИСЗ, а о них информация практически всегда есть.

2. Программа SatIR позволяет определять экваториальные координаты концов трека на фотографии, что является большим поспорьем для "метеорщикам". потому как именно эти данные, помимо угловой скорости и блеска, являются наиболее важными при обработке наблюдений.

Задачи "сателлитчика"-фотографа близки:

1. Фотографирую ИСЗ на широких полях наблюдатель при помощи SatIR может определять принадлежность ИСЗ (если заранее не известно, что за спутник сфотографирован).

2. Программа также помогает определять экваториальные координаты концов трека, что необходимо при вычислении орбиты новых ИСЗ или уточнении орбиты уже известных спутников.

Программа обрабатывает снимки и при наличие участков пейзажа.

В следующих пунктах данного справочного руковоства описаны основные шаги по работе с программой SatIR версии 1.7.

Оранжевым цветом выделены блоки с наиболее важной информацией, в серых блоках помещены примечания или уточнения.

При составлении данного руководства использовались фотографии Анатолия Григорьева ( granat , Россия) и автора программы.

Далее →

Created with the Personal Edition of HelpNDoc: Full featured Help generator

© TAU (satir.program@gmail.com)


Загрузка и разметка фотографии

Загрузка и разметка фотографии

При первом запуске программы производится создание файла астеризмов, что может занять некоторое время (до нескольких минут). В течении этого времени в отдельном окне отображается ход выполнения процесса. После окончания процесса создания астеризмов программа готова к работе.

Для того, чтобы открыть фотографию нужно пройти в меню "Файл" → "Открыть файл". При удачном открытии файла появится окно-превью с масштабированным файлом. Масштабирование производится таким образом, чтобы бо'льшая сторона превью не превышала 600 пикселов.

Программа SatIR поддерживает работу только с графическими форматами *.jpg и *.bmp!

При первом открытии кадра во время сеанса работы программы открывается директория программы. При последующих открытиях кадра – последняя директория (откуда был взят предыдущий кадр).

В нижней части основного окна программы находится вспомогательное окно-подсказка, в котором выводятся подсказки по работе с программой при активации той или иной функции программы.

Рядом с окном с фотографией также появится фрейм-окно. При перемещении курсора мыши по кадру во фрейм-окне показывается фрагмент кадра. Параметры фрейм-окна (размер и коэффициент увеличения) изменяются через меню "Разметка" → "Параметры фрейма". Центр фрейма отмечен перекрестьем.

Перед началом обработки кадра нужно ввести необходимую для отождествления кадра и трека информацию. В левом поле программы задаются параметры кадра:

● Дата получения кадра: в формате ДД.ММ.ГГГГ - например 12.04.2012. Учитывайте, что при указании даты снимка, полученного вблизи полуночи, дата может не совпадать с местной, т.к. дату нужно вводить по Всемирному времени UT (GMT+0).

● Время получения кадра (по Всемирному времени UT) - время середины экспозиции (обратите на это внимание - при длительных экспозициях это может быть критичным).

● Возможная ошибка по времени при получении кадра (для идентификации ИСЗ). Ошибка UT используется только при поиске претендентов. Временной диапазон расчёта увеличивается на +/- величину ошибки по времени (к примеру, если время середины экпозиции 12:00:00, экспозиция 10 сек, а ошибка 5 сек, то траектория ИСЗ-претендента будет вычислена и показана на кадре (если трек ИСЗ не выходит за границы кадра) в диапазоне от 11:59:50 до 12:00:10).

● Экспозиция кадра с точностью до 0,1 с.

● Долгота места съёмки в формате ГГ.ггг - например 27.365. Пользователь может выбрать значение полушария: N - северное, S - южное.

● Широта места съёмки в формате ГГ.ггг - например 54.145. Пользователь может выбрать значение полушария: E - восточное, W - западное.

● Опция “Не учитывать видимость”. При выборе этой опции во время идентификации звёзд условия видимости звёзд (проверка условия "звезда над/под горизонтом") не учитываются. Эта функция только для идентификации звёздных снимков. Время идентификации при выборе этой опции увеличивается в разы, вероятность ложной идентификации также увеличивается.

Долгота и широта может быть выбрана из списка пунктов наблюдения. Для доступа к списку необходимо щелкнуть по графическому значку изображения списка. При этом откроется окно, в котором можно заполнить поля с кооринатами и названиями мест наблюдения и сохранить их в список, который будет храниться постоянно.

При заполнении полей списка можно указать 4-циферный COSPAR-код наблюдателя, который используется при оформлении астромтерии в формате IOD.

COSPAR - COMMITTEE ON SPACE RESEARCH, Комитет космических исследований, подразделением Международного Совета по науке, созданный для продвижения исследований в области космоса и расширения сотрудничества учёных в этом направлении по всему миру. Наблюателю ИСЗ может быть выдан четырёхциферный уникальный код, привязанный к месту наблюдения.

IOD - формат предоставления астрометрических данных по положению ИСЗ на небе наблюдателя в фиксированные моменты времени. Со структурой формата IOD можно ознакомиться на сайте [ spysat.narod.ru/format/IOD_format.html ].

Блоки "Дополнительные сведения" и "Параметры программы" заполняются самой программой по мере проведения необходимых вычислений.

Параметры кадра сохраняются в информационном файле в директории ./info программной директории. При повторном открытии кадра информационный файл будет загружен по умолчанию. Также можно открыть информационный файл вручную: меню "Файл" → "Открыть информационный файл".

Для идентификации звёзд их нужно сначала выделить на кадре. Для этого в меню выбирается режим "Разметка" → "Разметка звёзд". При наведении курсора в виде квадратика на звезду и щелчке мышью происходит определение растровых координат звезды. Оптимально подобрать размер фрейма таким образом, чтобы во фрейм не попадали другие яркие звезды. Количество выделенных звезд отображается в блоке "Параметры программы" основного окна программы, выделенные звёзды обозначаются на превью красным цветом.

После этого можно приступить к отождествлению сфотографированного участка неба.

← Назад | Далее →

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Отождествление участка неба

Отождествление участка неба

Для идентификации кадра необходимо не менее 4 звёзд. Желательно не отмечать более 20 звёзд, т.к. это увеличивает время идентификации. Для отметки звезды достаточно, чтобы она попадала внутрь курсора-квадратика. При успешном захвате звезды вокруг неё обрисовывается красная окружность. Чем объект ярче, тем больше радиус окружности. Если для звезды отношение "сигнал/шум" (SNR - signal to noise ratio) менее 10, то звезда не будет захвачена.

Режимов идентификации два, они задаются в блоке "Параметры пользователя" основного окна программы:

1. "Координаты ЦП не заданы": Режим без заданных координат поля (для полей размером 20о-80о градусов, не удовлетворяющие этому условию гипотезы программой не рассматриваются). Идентификация производится по звездам каталога до блеска 4m. Если в кадре недостаточно ярких звезд (менее трёх), то идентификация не произойдет, или произойдет ложная идентификация.

2. "Координаты ЦП заданы": Режим с заданными координатами поля и размером поля (для средних полей). Производится по звездам до блеска 8m. В режиме с начальными условиями ограничение на размер поля от 3о до 50о градусов. Неподходящие по масштабу гипотезы не рассматриваются.

Выбор режима производится в поле параметров. После выбора режима идентификации нужно произвести его запуск: меню "Идентификация" → "Идентификация звёзд".

В случае удавшейся идентификации необходимо проверить, не ложная ли она. Для этого необходимо посмотреть, как звёзды каталога соотносятся со звёздами на кадре - звёзды каталога будут отмечены белыми квадратиками разных размеров. Увеличить или уменьшить глубину каталога можно через меню "Визуализация каталога" → "Уменьшить/Увеличить глубину каталога не 0.5 mag".

В том же меню "Визуализация каталога" можно включить/отключить отображение маркеров вокруг звёзд каталога (опция "Показать звёзды каталога"), а также отобразить возле маркеров блеск звёзд (опция "Показать звёздные величины"). При перемещении курсора по кадру вверху окна отображаются экваториальные координаты точки под курсором (красным цветом - в формате ГГ.гг для прямого восхождения RA и склонения Dec, а ниже, синим цветом, в формате ЧЧ ММ СС для RA и ГГ ММ СС для Dec). На этом шаге получается глобальная привязка кадра.

После этого можно перейти к разметке трека на фотографии.

← Назад | Далее →

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Разметка трека

Разметка трека

После идентификации кадра можно измерить трек на кадре. Для этого необходимо отметить концы трека кадра. Режимов разметки концов трека два:

● Автоматическая разметка (для ярких треков). Выбирается в меню "Разметка" → "Автоматическая разметка концов трека". В этом режиме необходимо навести курсор-фрейм на конец трека и щёлкнуть клавишей мыши.

● Ручная разметка концов трека. Выбирается в меню "Разметка" → "Ручная разметка концов трека". В этом режиме необходимо совместить центр фрейма с концом трека. Для пиксельной подводки в этом режиме можно зажать клавишу <Ctrl> и стрелками <← ↑ →> на клавиатуре подвести центр фрейма к треку. При такой подводке, чтобы не двигать мышью, отметка концов трека производится нажатием сочетания клашиш <Ctrl> + <End> на клавиатуре.

В случае неудачной разметки концов трека можно начать заново, выбрав в меню режим разметки заново. Если отмечено два конца трека, то можно измерить их координаты с большей точностью только по близким

звёздам. Для этого выбираем пункт меню "Идентификация" → "Измерить трек". После измерения трека появится окно с результатами измерений.

Сначала в окне печатаются координаты по глобальной привязке (см. предыдущий пункт руководства), затем начинается локальная привязка по ближайшим к треку звёздам (звёзды локальной привязки обозначаются голубым цветом, эти звезды пользователь не отмечает, их программа сама пытается найти), которая лучше глобальной при условии, что линейная модель с 6 постоянными для кадра хорошо подходит.

На дисторсионных кадрах в любом случае такая 6-параметрическая модель будет работать плохо, и чем дальше от центра кадра, тем хуже, там линейная модель не подходит совсем.

Для оценки точности звёздной привязки в окне с информацией о результатах измерений специально выводятся параметры "О-С" для звёзд локальной привязки.

"О-С" - это разность между измеренными координатами звёзд на кадре и координатами звёзд по данным из каталога звёзд. Точность измерения трека складывается из квадратов ошибки звездной привязки и измерения самого трека.

Ниже "О-С" печатаются координаты трека по локальной привязке.

Теперь можно переходить к поиску спутников-кандидатов, которые могли оставить на данной фотографии свой след.

← Назад | Далее →

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Поиск претендентов

Поиск претендентов

Для идентификации ИСЗ на кадре необходимо наличие орбитальных элементов спутников в формате TLE. Файлы c TLE загружаются через меню "TLE" → "Ввести Tle из файлов". В появившемся окне нужно выбрать директорию и отметить те файлы, которые необходимо загрузить. В окне ввода TLE есть опция "Не вводить ИСЗ с перигеем больше чем" - такие TLE будут игнорироваться.

TLE - Two-Line Element set, двухстрочный элемент. Это двухстрочный формат данных, представляющий собой набор орбитальных элементов орбиты для спутника Земли. Структуру и расшифровку формата TLE можно посмотреть на сайте [ spysat.narod.ru/format/rasklad_TLE.htm ]. Часто они называются любителями жаргонным словом "тула'йн", происходящим от английской расшифровки акронима TLE.

В программе SatIR допустимые расширения для TLE-файлов *.txt и *.tle.

Не храните загрузочные файлы с наборами TLE в директории ./TLE, т.к. это программная директория и в ней появляется много программных файлов. После загрузки TLE, программа их читает и всё прочитанное складывает к себе в директорию ./TLE: дополняет файл с TLE по каждому ИСЗ или создаёт файл, если TLE по данному ИСЗ до этого не было. Программа работает только со своими файлами TLE: находящимися в директории TLE и имеющими название "номер.tle". Причем наборы TLE в файле отсортированы по "свежести" (чтобы не читать весь файл и сократить время на поиск подходящего набора TLE) , а в первых строках файла находится имя и блеск при их наличии. Эти файлы нельзя трогать и нельзя дополнять наборами TLE вручную, это внутренняя база данных.

Наиболее полный архив TLE на текущую дату можно скачать на сайте www.space-track.org , пройдя по ссылкам "Bulk Catalog Data Downloads" → "Three-Line Format (includes object names)". Этот архив содержит TLE-элементы для примерно 14000 ИСЗ. Среди них нету секретных спутников США и некоторых стран. TLE-элементы для некоторых ИСЗ, не вошедших в архив space-track.org можно скачать с сайта "сателлитчика" Майкла МакКанта (Mike McCant) по ссылке: classfd.zip . Этот архив TLE-элементов создан по результатам наблюдений любителей.

Программа постоянно пополняет собственную базу данных TLE-элементов, поэтом со временем размер дискового пространства, выделяемый под это, увеличивается (за год размер дирректории с архивом TLE может увеличиться на 400 МБ при достаточно регулярном обновлении TLE). Поэтому в программе предусмотрена очистка базы данных (меню "TLE" → "Очистка базы данных"). Отсекание "лишних" TLE можно проводить по высоте перигея, а удаление устаревших - по давности TLE (считая от текущего системного времени).

Если пользователь хочет видеть и имена ИСЗ-претендентов, то необходимо загрузить файл "SSR" ("Satellite Situation Report"), который можно скачать с сайта www.space-track.org , пройдя по ссылке "Bulk Catalog Data Downloads" → "SATCAT DATA" → "Satellite Situation Report".

Также есть возможность получить информацию о звёздной величине ИСЗ. Для этого нужно скачать файл "mcnames" (он не имеет расширения) с сайта Майкла МакКанта по ссылке: mcnames.zip . Из этого файла будет браться оценка звездной величины ИСЗ. Звёздная величина ИСЗ из файла "mcnames" показывается в разделе "Идентификация" → "Траектория конкретного ИСЗ" (конечно, если для данного ИСЗ известен блеск и он указан в "mcnames").

Наряду с именами ИСЗ из файла SSR, названия спутников берутся из файла mcnames и из трехстрочных TLE. При наличии двух имён для ИСЗ, преимущество отдается имени из файлов с сайта МакКанта.

Внимание: все файлы с TLE-элементами, названиями ИСЗ и их блеском должны быть распакованы.

При наличии TLE и отмеченных концов трека можно запустить задачу идентификации ИСЗ: меню "Идентификация" → "Поиск претендентов ИСЗ". В открывшемся окне задаются границы по периоду обращения ИСЗ и наклонению его орбиты.

"Угловая ошибка" - допуск на угловое расхождение между треком на кадре и ИСЗ-претендентом. "Ошибка наклона" - допуск на возможный угол между треком на кадре и траекторией ИСЗ-претендента. Для расчёта положений ИСЗ берётся набор TLE, ближайший к заданному времени экспозиции кадра.

Внимание: программа работает только по низкоорбитальным ИСЗ.

При обработке кадров после съёмки ИСЗ важно иметь TLE-элементы на дату, максимально приближенную ко времени съёмки. Иначе изменение орбиты ИСЗ исказит результаты при наложении треков. Если спутник известен и не "секретный", то TLE-элементы для него можно получить на сайте www.space-track.org , пройдя по ссылке "Retrieve TLE Data by Satellite Catalog Number" и введя номер ИСЗ (SCN) по каталогу NORAD и дату. Для остальных ИСЗ эта информация недоступна, поэтому наблюдателю следует периодически сохранять новые элементы и не удалять старые TLE-архивы.

SCN - представляет собой уникальный пятизначный порядковый идентификационный номер, присваиваемый всем ИСЗ.

В случае обнаружения ИСЗ-претендентов появится окно со списком. Щёлкая мышью по номеру претендента (SCN), можно увидеть, как траектории ИСЗ-претендентов ложатся на кадр в заданный промежуток времени. При наведении мышью на точку траектории показывается время положения ИСЗ в этой точке. Оранжевые отметки - ИСЗ освещён, серые отметки - ИСЗ в тени.

В списке претендентов для каждого ИСЗ выводится:

● Его номер по каталогу NORAD (SCN).

● Угловая ошибка (R) - максимальное угловое расстояние между треком на кадре и траекторией ИСЗ в заданный промежуток времени, т.е. максимальный перпендикуляр между треком и траекторией.

● Ошибка наклона (U) - угол между треком и траекторией ИСЗ.

● Давность TLE-элементов dt (модуль промежутка времени между эпохой набора TLE и временем кадра (середина экспозиции), выражается в сутках).

● Название ИСЗ (если файл SSR был загружен).

Список отсортирован на основе критерия минимума произведения R●U, которое минимально для наиболее вероятного кандидата, т.е. наиболее вероятный кандидат, как правило, находится в начале списка. Это правило не всегда это себя оправдывает, т.к. остаётся неоцененной ошибка вдоль траектории ИСЗ.

Для сохранения номера ИСЗ в информационном файле необходимо щелкнуть по графическому значку на форме со списком претендентов.

В окне списка ИСЗ-претендентов добавлен графический значок (синий с двумя треками), при клике на который выбранный номер (SCN) ИСЗ запомнится для функции рисования нескольких траекторий (см. ниже). Выбранные номера также запоминаются в информационном файле, и при следующем сеансе работы с кадром, в случае запуска функции рисования нескольких траекторий, номера ИСЗ будут введены в окно задания номеров ИСЗ. Шаг расчёта и цвет траектории не запоминаются.

Посмотреть траекторию отдельного ИСЗ можно через меню "Идентификация" → "Траектория конкретного ИСЗ". В этом окне выводятся вычисленные значения:

● Название ИСЗ.

● Давность TLE-элементов.

● Время (UT).

● Положения ИСЗ (экваториальные координаты RA и DEC).

● Фазовый угол (Ф).

● Блеск в звёздных величинах (mag) ИСЗ на время каждого шага расчётов.

● Дальность до ИСЗ в км (po).

Здесь также можно запомнить номер ИСЗ, щелкнув по графическому значку с карандашом. Щелчок по значку с "летающей тарелкой" приведет к созданию файла астрометрии в формате IOD. В файл астрометрии вносятся данные по отмеченным концам трека, вычисленные через локальную привязку (если она была выполнена), или вычисленные по астрометрическим параметрам всего кадра, если локальной привязки не было. При создании файла измерений направление движения ИСЗ на кадре будет считаться соответствующим движению выбранного ИСЗ.

В программу SatIR версии 1.6 добавлено рисование траекторий нескольких ИСЗ (меню "Идентификация" → "Траектории нескольких ИСЗ"). Траекторий может быть не больше 15. Для добавления поля ввода нового ИСЗ нужно нажать на кнопку “Добавить ИСЗ”. Для каждой траектории можно задать свой цвет рисования: для этого нужно после введения номера и/или шага времени для данного ИСЗ кликнуть мышью по цветовой карте (с какого ИСЗ был перенесен фокус - тому цвет и присвоится). При выборе опции “Подписать траектории” траектории будут подписаны тем же цветом.

Траектории ИСЗ удаляются с фотографии после закрытия окон: ИСЗ-претендентов, траектории конкретного ИСЗ, траекторий нескольких ИСЗ.

← Назад | Далее →

Created with the Personal Edition of HelpNDoc: Full featured Help generator


Об авторе

Автор программы: Елена (aka TAU ), satir.program@gmail.com

Автор справочного руководства: Виталий Мечинский, Lupus@belastro.net

← Назад

Created with the Personal Edition of HelpNDoc: Free Web Help generator